LVM Disk Replacement (SAN Disk)

Problem Definition

Normally we will not see any evidence of failed disks, as they are hot-swapped out automatically without needing our invervention. If a SAN disk failure does cause stale partitions, the the following procedure should be followed.

Please note that this should ONLY be used for SAN disk: if the failed disk is an internal disk then the LVM Disk Replacement (Internal/Root Volume) procedure should be followed.

Resolution

• Identify disks as per normal procedure EMC replacement procedure.. i.e. from inq/metas etc.. and associated AIX hdisk numbers.

• Find volume group disk(s) are associated with - note the hdisk number and PVID . The PVID can be used in place of the hdisk name if the disk is marked as missing.
lspv

• Find logical volumes associated with disk (repeat for each disk to be removed)
lspv -l 'hdisk'

• Remove mirrors from that disk
rmlvcopy 'lv' 1 'hdisk(s)'

• Remove disk from volume group
reducevg -f 'vg' 'hdisk(s)'

• Remove disk from AIX to defined state (repeat for each disk to be removed)
rmdev -l 'hdisk'

• Once disk has been replaced
cfgmgr

• Ensure disk replaced is now available, double check with inq
lsdev -Cc disk -S1

• Add disk back into volume group
extendvg -f 'vg' 'hdisk(s)'

• Recreate logical volume copies
mklvcopy 'lv' 2 'hdisk(s)'

• Resync to volume group
syncvg -v 'vg'